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Explore & Evaluate Flash Projects

Explore Flash projects from the list found at http://eduscapes.com/flash/explore.htm
Before you jump into evaluation, be sure to record background information about the evaluation 
environment: project name; summary of audience, purpose, contents; URL or access point; oper-
ating system and web browser, version of Flash plugin, date of evaluation.

Overall Impressions
Is this project a good use of Flash?
Would an animated gif be just as effective?
Would a movie be as effective?
Would a still graphic be as effective?
Would a text page with graphics be as effective?
Is the overall project appealing and inviting?
Is the project an effective model for other developers?
Does this project offer content or an approach not available elsewhere?

Audience and Purpose
Is the project purpose and sponsorship immediately clear?
Is the “look and feel” of the project appropriate for the audience and purpose?
Does the project address the demographics of the primary audience?
Does the project address the needs or interests of the users?
Is the project flexible enough to accommodate varied learning styles?
Are the materials developmentally appropriate for the primary audience?

Content
Are informational, persuasive, and/or teaching strategies applied effectively?
Does the project contain accurate, high quality content (i.e., interesting, useful resources)?
Is the authority of the project clear?
Is the content objective, opinions identified, and perspectives balanced?
Are authentic resources used (i.e., quality graphics, established sources, primary materials)?
Is the content timely and current?
Is the content relevant, useful, and meaningful to the intended audience?
Is the content presented in an efficient and effective manner?
Is the breadth of the content effective (i.e., goes beyond basic facts and data)?
Does the depth of content match the varied audience needs (i.e., text explanations, audio, 
choices for more depth)?
Does the project provide resources that go beyond the ordinary (i.e., unique, local, special)?
Does the project contain a mix of content formats (i.e., text, graphics, photographs, video, au-
dio) to address specific needs?
Is the content logically organized?
Does the project contain current, timely information?
Is the project free from spelling, grammatical, and other typographical errors?
Is any writing clear and appropriate for the developmental and reading level of the audience?
Is the content presented in a variety of ways to meet individual differences (i.e., text, graphics, 
photographs, diagrams, audio, video)?
Is there quality content beyond links?

Organization
Does the project contain a clear introduction and organized elements?
Are events presented in a logical sequence?
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Design
Is the project visually appealing?
Do audio elements contribute in a positive way?
Do the colors attract rather than distract?
Is adequate contrast provided between elements in foreground and background?
Is the project creative and imaginative?
Does the project maintain audience attention?
Does the project have an effective introduction?
Does the site make appropriate use of fonts (i.e, font type, style, size, color, ease of reading)?
Were fonts effective and easy to read?
Were font colors appropriate for ease of reading?
Does the project make effective use of foreground colors, background colors, and/or images?
Is the visual layout effective and visually appealing?
Does the graphic design reflect the purpose of the site (i.e., serious, whimsical, visually inter-
esting)?
Is the design attractive for the intended audience?
Is there a consistent theme or layout throughout the project?
Does the graphic design add to (not distract from) the site?
Is the visual layout consistent, well-organized and free from clutter?

Navigation
Are directions or help provided for use of icons, navigation, or interactive elements?
Is effective navigation (i.e., menu, buttons, limited options) provided as needed?
Are helpful information retrieval tools (i.e., site map, index, search engine) provided?
Is the navigation appropriate for the audience?

Technical - Overall
Does it load quickly and provide information about loading time?
Does it flow smoothly from start to finish?
Do all graphics, animations, text, and other page elements appear in their proper places?
Are directions provided for running or using the project?
Are directions provided for downloading the Flash plug-in?
Are transitions smooth, consistent, and not distracting?

Technical - Animation
Does the animation contribute to the effectiveness of the project?
Does animation attract rather than distract users?
Is animation used in meaningful ways?

Technical - Interaction
Does the interaction contribute to the effectiveness of the project?
Do interactive elements function effectively?
Do interactive elements contribute to understanding rather than confusion?
Is feedback or the result of interaction clear and effective?

Technical - Multimedia
Does the multimedia contribute to the effectiveness of the project?
Are media attributes used effectively without being distracting?
Do the media elements address alternative learning styles?
Were media elements clear and easy to understand and/or interpret?

Accessibility
Do the materials meet the requirements of special needs users in the primary audience?
Do the materials meet the Section 508 accessibility standards?
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Flash Exploration: Simple Animated Banner

Let’s create a simple animated banner and put it on a web page.
Open Adobe Macromedia Flash. (Flash CS3 instructions)
Choose Create New and Flash File (ActionScript 3). 
Save the document and give it unique name such as stickpeople.fla.

Set Page Properties
You’ll see tools on the left. Menus across the top. Below is the Timeline, then the Stage.
The Properties should show across the bottom of the screen. (or locate in Windows menu)
Let’s make a web page banner. Change your size to 550 x 100 pixels.

Create a Picture for Simple Animation
Draw a simple stick person on the extreme left side of the screen. 
	 You could also draw a globe, basketball, car, or other object.
For a circle, click the Rectangle tool and draw a circle. Use the line tool to create lines.

Create Simple Animation
The default setting is 12 frames per second. Let’s create movement every 5-10 frames.
Click on Frame 5. Pull down the Insert menu, choose Timeline and Keyframe. Note the dot.
Click on Frame 15. Add another Keyframe. Also add Keyframes on 20, 25, 30, and 40.
Click on Frame 1. Pull down the Edit menu, Select All. Pull down the Edit menu, choose Copy.
Go to Frame 5. Pull down the Edit menu, choose Paste. Go to all the other frames and paste.
Go back and make small changes on each Keyframe such as moving legs or arms. You can 
also go to the Modify menu and choose Transform to make changes such as rotation.
To test your animation, pull down the Control menu and choose Test Movie.
Pull down the File menu, choose Export, and Export Movie.

Place Animation in a Web Page
Open Dreamweaver. Choose a New HTML document. Save the document.
Pull down the Insert Menu, choose Media and Flash.
Locate your stickpeople.swf file. Add a Title and choose OK.
Pull down the File menu and choose Preview in Browser. You did it! Super Cool!
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Build a Hot Air Balloon

Open Adobe Macromedia Flash. (Flash CS3 instructions)
Choose Create New and Flash File (ActionScript 3).
	 The blank work area is called the Stage.
Save the document and give it unique name such as balloon.fla.

Use Graphic Tools
Let’s create a hot air balloon using the graphic tools at Layer 1, Scene 1, Frame 1.
Use the Tools Palette to create the balloon.
Suggestions:
Create a balloon in the lower left Stage corner.
Use the Rectangle for basket.
Click the Rectangle, drag to choose an Oval.
Draw a oval for your balloon.
Use the Pencil to complete the balloon.
Use the Stoke and Fill Color for color.
Be sure to save your work.

Create a Graphic Object
Let’s turn our balloon into a graphic object we can reuse from the Library.

With the Selection tool, select the entire hot air balloon figure.
	 Or Pull down the Edit menu and choose Select All.
Under the Modify menu, select Convert to Symbol.
	 Name your graphic balloon1. Choose Graphic for your Type.
	 Click the center box the Registration area. Click OK.

Notice the balloon is now showing in the 
Library Window. 

Add Another Layer
Rename Layer 1 as balloon. Let’s create 
another Layer for the cloud and birds. 

Click the Insert Layer button. Or, choose Insert, Timeline, and Layer.
As you create and add other graphic images (cloud, bird), you should save them to the Library 
as Graphic objects. Images and sounds can also be imported into your Library. You can drag 
images from your Library onto the Stage. You may want lots of birds. Be sure to Save!

Setting the Length
To use our hot air balloon graphic in a short Flash movie, we need to decide how long 
our movie will be, using the standard frame rate of 12 frames per second. 
Let’s make a 10-second movie with 120 frames.
Scroll over to Frame 120. Click in Frame 120.
	 If you had multiple Layers, you can shift-click to select both Layer 1 and Layer 2.
Pull down Insert menu, choose Timeline, and select Frame.
Notice the last frame (120) now has a white rectangle and the layer(s) are gray,
indicating they now contain content including your balloons and your birds.

Selection

Subselect

Freeform select
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Pen

Text

Line

Rectangle

Pencil 

Brush

Ink Bottle

Paint Bucket

Eye Dropper

Eraser

Hand

Zoom
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No Colorbird graphic object

New Layer

Select Location

Create Frame
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Animation

Make the Balloon Rise
Let’s use animation to make your hot air balloon rise up into the sky.
There are different ways of creating animation including: (1) frame-by-frame (labor intensive 
but can be very effective), (2) motion tweening (set beginning and end points and letting the 
computer complete), (3) shape tweening (computer morphs one shape into another), and (4) 
ActionScript (using ActionScript programming to move objects.

Creating Motion Tween Animation
The most common and perhaps easiest method for Flash animation is motion tweening.
(Note that you can only use graphic symbols (the balloon image) and movie clips for motion 
tweens.) Steps for using motion tween to make the balloon rise:

	 Select Frame 120 on the Balloon Layer.
	 Pull down the Insert menu, select Timeline, then select Keyframe.
		  Notice the black dot indicating the Keyframe.
	 Make sure that your layer with the balloon is unlocked (no lock on the layer).
	 Next, drag the balloon to a final position in the upper part of the Stage - directly above itself.
	 A Motion Tween will span the space between the starting point (Frame 1) and Frame 120.
	 The Tween programming is associated with the Keyframe starting point.
	 Therefore, click Frame 1 of the Balloon Layer.
	 Go to the Windows menu, choose Properties (it may already be showing below the Stage).
	 Look for Properties panel, choose Motion from the Tween drop-down menu.
	 (Notice that an arrow on the layer timeline now connects the 	
	 starting Keyframe to the end Keyframe.) 
	 If you haven’t done so recently, save your work.

The Flash software has automatically moved the object frame-by-frame in a direct path from 
the starting point to the ending position. Let’s take a look at your animation. 
Pull down the Control menu, select Test Movie (Also called Test the swf File) to create the swf 
file and show your animation. Pretty cool! 

Modify the Balloon Path
Try different movements; instead of straight up. At this point, you can still change the location 
of the balloon on Frame 1 or Frame 120 to adjust the path.
Notice that the movement is limited to a direct path created by the computer.
Our next step is to move the balloon sideways, or in other varied patterns by other methods.

Using a Motion Guide
Taking the Flash program that you have already created,
	 let’s modify it using a Motion Guide:

Click on the Balloon Layer.

Click the Add Motion Guide button 
	 above the Stage on left side below the main Timeline.

Motion Guide

Balloon Layer

Motion Guide Button
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You have just created a Guide layer as a subset of your balloon layer.
	 (This new Motion Guide layer appears above the other).
Again, you first set the end point (frame) for this guided motion.
In the Guide layer, click on Frame 120.
Pull down Insert menu, choose Timeline, select Keyframe to set the end point.
On the Guide layer, select Frame 1.
For this to work, your image must be a (graphic) Symbol (Shown in the Library).

Ready to create a path for your Motion Guide?

Select the Pencil (or Pen) Tool  and click on the exact center of the balloon (On the stage).
	 You can use the Selection Tool to grab and display that center of the balloon image. But 		
	 remember to draw your path with the Pencil / Pen Tool, you have to return to Frame1 of 		
	 your Guide layer.
Starting at that balloon center, draw a path on the stage for your balloon to follow - from the 	
	 beginning to end point. Get the start and end points as close as possible. The type of line 	
	 and the technique used to complete the line are different for each tool (Note that if you use 	
	 the pen, you have to click end points for each line segment, connecting each to the next.
When your path line is drawn, switch to the Selection Tool. Click in the first frame of the Bal-
loon Layer where your balloon is located. Adjust the position of the balloon so that the dot in 
the middle of the selected area is at the beginning of your motion guide. 
Go to Frame 119 of the Balloon Layer and move the image so the line ends at the dot.
If it still does not work, make sure the Snap to Objects is selected under the View > Snapping 	
	 menu.
Note: There are two ways to preview your Flash movie. (1) On the Timeline, drag the Playhead 	
	 from start (Frame1) to finish. This is called “scrubbing” the timeline. 
	 (2) Pull down the Control menu and choose Test Movie.

Create Shape Tweens with a New Project
It’s sometimes easiest to learn a new skill with a fresh project, so let’s set aside our balloon 
project for a few minutes. Be sure to save it.
Open a new document. Let’s create an alphabet book. We’ll start with an apple and change it 
into the letter A.
Click in Frame 1 of Layer 1.
Choose the paintbrush and the color red from the paint bucket. 
Draw an apple in the lower left corner of the screen.
Select it. Pull down the Modify menu and choose Convert to Symbol, Graphic. 
	 Now it’s in the Library in case you need it later.
Select your apple and pull down the Modify menu and select Break Apart. 
	 This will turn your apple into tiny pieces.
Go Frame 20 and Insert a Keyframe. Click on this Frame.
Use your paintbrush to draw a letter A on the right side of the screen.
Select your A. Pull down the Modify menu and choose Convert to Symbol, Graphic. 
	 Now it’s in the Library in case you need it later.
Select your A and pull down the Modify menu and select Break Apart. 
	 This will turn your A into tiny pieces.
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Go back to Frame 1. 
Look below the Stage for the Proper-
ties window. 
Choose Shape from the Tween drop-
down menu. 
Scrub the Timeline to see your results!

Create and Animate Fireworks Using Shape Tween
Now, let’s return to our hot air balloon example.
Open the file. You may wish to lock (use the lock icon on the Timeline) or hide (use the eye 
icon on the Timeline) some of the objects, so it’s easier to concentrate on your current project.
In the interest of time, your Flash program is relatively sparse.
But if you wanted to, you could easily add building(s), tower(s) - - a cityscape, clouds, a sun, 	
	 grass, a sky background, and various other elements to the stage. You can draw your own 	
	 artwork as you did with your balloon, or you could import line art or clip art.

To gain one more animation technique for your Flash project, let’s try creating an exploding
	 firework. 

Here the guidelines are going to be fairly flexible.
Create a new layer called Fireworks and select the Layer.
Select a segment of 30-45 frames for your fireworks animation.
	 (30 to 60, 60 to 95, 70 to 115, 45 to 75 or something similar)
Within the new layer, click on the frame number of your selected starting point.
Create the beginning of your fireworks display: under Insert, select Timeline and Keyframe.
Click on the small circle to the right of the rectangle icon of the Keyframe (Within the layer).
Now you are ready to draw your first image of a firework explosion . . .
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In the clear, open space of your stage - - draw your exploding fireworks.
	 (Can be series of lines or a shape drawn by pen or pencil tool)
Think of this fireworks as the first stage of it’s explosion.
	 If you wish, select and adjust the size using the Modify > Transform > Scale menu.
Do not group the image! Select all of it and play around with editing line thickness, 			 
colors until you have something you like.
	 (You should save a copy as a graphic in the Library with unique name).
Leaving your first fireworks image upgrouped, now draw or copy/paste a second image of what 	
	 you imagine the final look for of your fireworks. This can be just a larger version or an
	 entirely different image.
When you have the second fireworks image as you like, also save it to the library.
Once saved, you can delete it from the stage at the starting point frame - should have your first 
	 version there, ungrouped, in the location that you want it to appear.
Select your end point and Insert > Timeline > Keyframe, click on the circle icon and paste in
	 your second fireworks explosion. Check that the image has been broken apart
	 (ungrouped): Modify > Break Apart
Return to the starting point in the layer, click on the circle icon for the Keyframe.
Look below the Stage for the Properties window; if it’s not there (something else in place - 
	 Click a second time on the circle / Keyframe.

In the Properties panel, choose Shape from the Tween drop-down menu.
	 Select Angular Blend or Distributed Blend type.
Scrub the Timeline to see your results.

Interaction
In Flash, it’s also possible to create interactive components to make your project interactive.
Regardless of the type of interactivity, an authoring language called ActionScript is used.
All interactions have two elements: events and actions.
Events are the triggers while a Flash program is playing; i.e., a button is clicked to have a 
	 sound play, or cause other parts to appear or disappear, or cause data to be sent to a
	 database.
ActionScript coding is placed in the ActionScript Window.

The Flash software contains a collection of prewritten scripts for common actions. This allows 
you to incorporate some interesting interactive elements before learning how to directly code 
ActionScripts.
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Adding an ActionScript
You may have noticed that your Flash movie plays over and over again in a loop.
To stop the program after it plays, you need to add an ActionScript. 

Create a new layer; call it action.
Select Frame 120 on the action layer.
Pull down the Insert menu, choose 
Timelines and Keyframe to add a 
Keyframe.
	 Note: We need a keyframe in 
any location where something will 
happen or appear.
With the keyframe (Frame 120 on 
the Action Layer) selected, pull 
down the Window menu.
Select Actions.
The Action panel will appear on 
screen. Notice that we’re using 
ActionScript 3. You can choose the 
command or write it directly into the 
script. 
Type the code in the window:

stop();

Test your Flash movie. It should play through one time and stop on the last frame.

Link to  a Website 
You will probably do some code or scriptwriting yourself, particularly if you work extensively 
with the program. However, you can create lots of interesting actions using prewritten scripts 
for common actions.

Let’s try another technique to create a hyperlink in our Flash program that takes the viewer to 	
	 more information about hot air balloons in the forms of a website resource.

There are lots of good websites about hot air balloons such as:
	 How Hot Air Balloons Work by T. Harris at howstuffworks
		  http://travel.howstuffworks.com/hot-air-balloon.htm
	 Hot Air Ballooning http://www.hotairballooning.com/
	 Or another site you prefer? . . . http://www.fireworksafety.com/

But first, we just need to have a button placed on Frame 120. 
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Linking to Websites
Let’s make a button we can use for our web link.
Create a new layer called Websites.
Create an oval.
Use the text tool to add a phrase like firesafety website.
Select your button. 
Pull down the Modify menu, select Convert to Symbol. Name it and choose MovieClip.
You need to give your MovieClip an Instance Name. Click on the MovieClip once to select it.
In your Properties window, give this button the name cool_button_mc.

Open the Action Window.
Be sure your are in Frame 1 of the Buttons Layer.
You’ll need to add an event listener to the button to listen for the user’s click, create the onClick 
() event handler, then add your request. It may seem complicated, but you can copy this copy 
from the website if you wish.

	 var link:URLRequest = new URLRequest(“http://fireworksafety.com”);

	 cool_button_mc.addEventListener(MouseEvent.CLICK, onClick);

	 function onClick(event:MouseEvent):void
	 {
		  navigateToURL(link); 
	 }
	 cool_button_mc.buttonMode = true;

If you have trouble when 
copying from the web, 
retype the quotation marks. 
Sometimes the characters 
get messed up in the copy-
ing process.
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Multimedia

You can insert both audio and video into your Flash works. However you cannot create / record 
audio and video components within Flash. Rather you can create and edit these elements with 
other software tools and then incorporate them into your work. 
Note: multimedia components should not be viewed or used as “extras” or supplements to be 
added as time allows. Instead audio, video and visual elements should be planned as integral 
components created to meet particular needs; i.e., address needs or interest, information, 
instruction, etc. Users’ ability to hear and see multimedia components can be dependent on 
installed players and plugins on their computers.

From music clips to sound effects, there are a variety of ways to incorporate sound into a Flash 
project. Let’s add a fireworks sound effect to our project!

If so, go to the Find Sounds website at http://www.findsounds.com/
Search for ‘firework’ and select a sound; download (copy) one that you like to your desktop.
To download, right-click on the sound icon and choose Save Link As.
Note: You can import several formats of audio files including *.wav, *.mp3, and *.aiff. A wav file 
works well for brief sound effects, but on longer audio clips you may have better sucess with 
the mp3 format.

Add Fireworks Sounds
Next step for using the fireworks sound in your Flash project is to import it into the Library:
	 Click on the Stage or a Keyframe in the Timeline.
	 Pull down the File menu, choose Import, select Import to Library (A dialog box will appear).
	 Locate the sound you have on the desktop.
	 Select and click Open.
	 Nothing changes on the desktop, but the sound file is added to your Library.

To embed this sound in the project, you should create a new Layer called Sound.
Select where you want the sound effect to begin playing and click on that frame in the sound 	
	 layer.
Add a Keyframe on the layer.
With that Keyframe selected drag your sound file from the Library onto the Stage.
Save the project and test your Flash movie.
For fun, create another later called Sound 2 and add the same sounds beginning at a different 
frame.

Sound files can also activated by button(s) and ActionScripts in your Flash work. Consider 
what other sound files could contribute to your project.

Flash Video
Video is an excellent way to add movement to your projects. It can provide closeup, larger-
than-life views and is essential in situations where motion content is critical. Video can also 
contain audio elements, be used without a soundtrack, or have added voiceover narration and 
sounds.
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We recommend that you try to keep video clips down in length to about 10 seconds, and also 
limit there image size - - to avoid overly large files and difficulties in moving and playing them 
via the Web. If longer videos are needed, consider streaming video from a web server with the 
needed video capacity. Video can be streamed from a specialized Flash video server.

From Flash programs that you create locally, you can connect to an .flv video played from a re-
mote web server. An added benefit is that the long video program can be setup to begin play-
ing while the download is still in progress (Fast-start video).

Publishing

Type Types
You can save your project as an FLA or SWF file. These can be easily shared.

The FLA file (Macromedia Flash Project file) is a uncompressed source Flash file that contains 
all animation and graphic. An important factor about FLA files are that they are editable.

SWF files are typically derived from a FLA file. SWF files are proprietary vector graphics files  
produced by the Macromedia Flash software. SWF files are compressed and uneditable. An-
other important factor is that they contain the embedded fonts from the original FLA file.

A SWF file automatically generated when you test the movie. It can also be created by export-
ing the file.

Embed in web page 

We can link to our file on a web page. We can also embed an SWF file.

Your Own Project

This handout provides a QuickStart to Flash. We recommend that you complete all of the read-
ings and activities at the Flash website for a more comprehensive look at Flash Basics.

http://eduscapes.com/flash

When designing your project, we find that it’s helpful to do some drawings. Some people like to 
use post-it notes or cards. Others simply jump right in. Either way, it’s important to plan. Who is 
your audience? What do you want to say? How will end-users interact with your project?


